Не отправляется отчет "Сведения о трудовой деятельности работника СЗВ_ТД" в ЗУП КОРП. Что делать?

Фанис Фахрутдинов, 19 августа 2021
Не отправляется отчет "Сведения о трудовой деятельности работника СЗВ_ТД" в ЗУП КОРП. Что делать?
1С:Предприятие 8.3 (8.3.18.1289)
Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.18.151) (http://v8.1c.ru/hrmcorp)
Copyright © ООО "1С-Софт", 2010 - 2020. Все права защищены
(http://www.1c.ru)
Расширения конфигурации:
- Экстерн (2.18.6)
- Экстерн, специальные возможности для Бухгалтерии предприятия 3 (1.1.1)
- ke-lib v1 (1.1.1)

Не отправляется отчет "Сведения О Трудовой Деятельности Работника СЗВ_ТД" через расширение

Ошибка:
Не удалось отправить (См. подробности в журнале регистрации.)
{ke Обработка.KonturExtern.Форма.КЭ_Исключения.Форма(196)}: ВызватьИсключение ЗаголовокИсключения(Заголовок, ИнформацияОбОшибке);
{ke Обработка.KonturExtern.Форма.Управляемая_ФормаОтчета.Форма(847)}: ОбщиеМодули.КЭ_Исключения.ПоказатьИсключение("Не удалось отправить", ИнформацияОбОшибке());

// Подпись
SignatureValue = КЭ_КриптографическиеФункцииРасширенные.ПодписатьXMLDSig(SignedInfo, СертификатПодписи);
Если SignatureValue = Неопределено Тогда
ВызватьИсключение "Не удалось подписать";
КонецЕсли;

&НаКлиенте
Функция ПодписатьXMLDSig(ИсходныеДанные, Сертификат) Экспорт
// Отладка
КЭ_Исключения.ЛогДобавитьОтладка(
"КЭ_КриптографическиеФункцииРасширенные.ПодписатьXMLDSig",
ИсходныеДанные,
Сертификат);
// Конец Отладка

СертификатBase64 = КЭ_КриптографическиеФункции.ВыгрузитьСертификатBASE64(Сертификат);

#Если ТолстыйКлиентОбычноеПриложение Тогда
ДанныеПодписи = ПолучитьКомпонентуXMLDSig().Sign(ИсходныеДанные, СертификатBase64, Сертификат.Пароль);
#Иначе
Если Сертификат.НаСервере Тогда
ДанныеПодписи = ПодписатьXMLDSigНаСервере(ИсходныеДанные, СертификатBase64, Сертификат.Пароль);
Иначе
ДанныеПодписи = ПолучитьКомпонентуXMLDSig().Sign(ИсходныеДанные, СертификатBase64, Сертификат.Пароль);
КонецЕсли;
#КонецЕсли

Возврат ДанныеПодписи;

КонецФункции
Сохранить
Отменить
3 2
У меня такой же вопрос У меня такой же вопрос
46 просмотров
В избранное
1 комментарий
https://kontur.ru/extern
Елена Кулакова, эксперт 20 августа
Добрый день!
С этим вопросом лучше обратиться на линию технической поддержки.
 Вернуться

Похожие вопросы

Показать еще вопросы... Нет подходящего вопроса? — Задайте свой вопрос.

Статьи на эту тему

Ничего не найдено. Задайте свой вопрос
Экстерн

Заполнить форму СЗВ-ТД или загрузить готовую и сдать через интернет бесплатно.

Узнать больше